Skip to end of metadata
Go to start of metadata

The IGB Sequence Viewer displays sequence data in a text-based window. When you right-click a selected item in the main display window or select a region of genomic sequence, IGB displays a menu offering View Genomic Sequence. You can access the same functionality using the View menu.

The viewer offers options to display protein translations and reverse complements. You can also copy the sequence to the system clipboard.

By default, the viewer depicts bases in yellow on a black background. Use the Colors menu to change the color scheme to Blue on white (exons in blue and introns in black)

View genomic sequence from sequence axis selection

To select genomic sequence, click-drag the selection cursor over the sequence bar.

When you select genomic sequence, a red outline appears around the sequence you selected. IGB shows the number of bases you selected and other information in the Selection Info box - top right. 

Icon

This method of genomic DNA selection also allows a direct copy to the clipboard, if you wish to skip the Sequence viewer. Simply right click within the selected sequence, and chose Copy.

To view the selected sequence in the Sequence Viewer:

  • right-click within the selected area
  • select View Genomic Sequence

or

  • select View > View Genomic Sequence from the main IGB menu

View genomic sequence for gene models or other annotation types

To view sequence for a model or other annotation type:

  • Right-click the annotation
  • Select View Genomic Sequence

or

  • Select View > View Genomic Sequence from the main IGB menu

 

Icon

To choose a single exon (part of) a gene model, right-click the exon. To choose the entire gene model, right-click any of the introns or the label, if available.

 

Working with the Sequence Viewer

Choosing View Genomic Sequence opens the Sequence Viewer as shown below. By default, the viewer depicts exonic bases in yellow and intronic bases in white against a black background. The start codon (ATG) is shown with a green box around it, and the stop codon has a red box around it.

Sequence Alignments

The Sequence Viewer has a special option for display of sequence associate with alignments. If you click a sequence alignment and select View Genomic Sequence you will see the genomic sequence that the read is aligning to. If you select View Read Sequence, IGB will show the aligned sequence, not the genome. This includes any unaligned, inserted sequence. Deletions appears as appea as a dash (-) characters.

Sequence viewer features for showing annotated gene models

Show cDNA

After selecting a gene model, the Sequence Viewer allows you to select Show cDNA, which will eliminate introns from the displayed sequence. We recommend selecting this option before using the translation feature. If an individual exon is selected, this button will be available, but will not change the sequence.

After selecting this feature, you'll see just the exonic (block) sequence, and the button will read Show Genomic

Show translation

Translation options are accessed from the Show menu. Reverse Complement provides the reverse complement in place (changes what is displayed). The Complement provides the complement under the main sequence. The + (forward) translations appears over the sequence; the - (reverse) translations below. To copy these translations, see Copy below

Copying and Saving Sequence

You can copy selected sequence from IGB main window or from the Sequence Viewer.  To copy sequence from the Sequence Viewer, click-drag over the region of interest (as shown below) and select Copy > Copy Selected DNA Sequence.

Copy DNA with Lowercase Introns and Start/Stop Codons which copies the DNA sequence with the annotations. When you paste this sequence, you will be able to determine intron and exon boundaries, and find the annotated start and stop codons within the nucleotide sequence. This can be very helpful for PCR primer design or alternative splicing studies.

Copy Annotated Translation copies the annotated translation for the selected gene model - no highlighting needed.

Copy Selected Translation(s) copies all translations being shown visible in the Sequence viewer.

You also have the option to save the sequence directly from the viewer into a fasta file. Fasta files can be shared and used for bioinformatics in this file format, but fasta files can also be opened and viewed from any text editor to access the sequence directly. The file will contain the sequence as well as a line with all of the relevant information from the title of the sequence viewer window. We allow you to save the sequence directly or in the reverse complement, as you need. Open File > Save As Fasta or Save As Fasta (reverse complement)

You can export an image file showing the Sequence Viewer using the Save Image function.

  • No labels