Skip to end of metadata
Go to start of metadata

Introduction

IGB display reference genomic sequence in the Coordinates track. IGB supports many interactions and views on genomic sequence, including copying sequence, viewing sequence in the Sequence Viewer, and running BLAST searches. Other features may be available via IGB plug-ins.

Loading reference genomic sequence data

IGB does not load genomic sequence until you request it, giving you total control over how much data is loaded and when.

To load genomic sequence

  • Click Load Sequence button

Sequence data will then load from a remote data source or local file, depending on whether you're viewing a genome version supported by an external data source or if you're viewing a genome you loaded using the Load Custom Genome option.

Icon

If you are working with a genome that is not supported by the IGBQuickLoad data source, let us know. It is easy to add new genome versions to IGBQuickLoad.org.

Icon

Some external sequence data servers will reject requests for residues from a region that is too large. Others will return the data, but only after a very long wait. If you have problems, let us know.

What to do if your genome is not supported

If you have a sequence file in one of the formats that IGB can read (File Formats), you can use that sequence as a reference sequence.

To use your own file as the reference genome sequence

  • Choose File > Open Custom Genome
  • Enter a species name into the Species text box
  • Enter a genome version name into the Genome Version text box
  • Use the "..." button to browse and open your reference sequence file
  • Click OK

IGB will then open the file and it will appear in the Data Management table.

To load data, click Load Sequence button (NOT Load Data) to view the sequence in the coordinate axis.

Icon

If the chromosome names do not follow standard synonym conventions you may need to create a personal synonyms file. See: Personal Synonyms.

Icon

If the sequence length contradicts your annotation files, IGB will not be able to display them together. Please contact us if you need help.

Loading sequence into a new track

If you want to load an additional sequence as a track rather than as a reference sequence (perhaps a substrain or an individual), open it as if it were an ordinary file.

  • You can drag and drop the file into IGB from either a desktop folder or from a URL.

or

  • You can also choose File > Open File... or Open URL....
  • Click Load Data to load the sequence into the track

As with any other track, a new empty track will appear labeled with the name of the file you opened. The file name will appear in the Data Management table in the Data Access tab.

Viewing the reference sequence

At low zoom (many bases are shown) loaded sequence is shown as a gray bar beneath the coordinates axis.

When you are zoomed in, the sequence bases become visible. If sequence has not yet been loaded, '-' (hyphen) characters are shown. If the sequence is loaded, the nucleotide base letters are shown. By default, IGB uses cool colors to represent A and T bases and warmer colors to represent G and C bases.

Change base colors in the Preferences > Other Options tab.

Icon

Note that depending on the sequence data server, file, or URL that supplied the sequence data, bases may appear in upper or lower case.

Examples

In the first image, you can see a sequence loaded as a track (red arrow). Notice that the refseq has not yet been loaded (blue arrow) so it appears gray with '-' marks; when you are zoomed out,  the sequence track shows a gray bar (default color), and the coordinate axis is empty.

After loading the refseq (red arrow), the sequence in the track (yellow arrow) changes to the FG color for that track (cyan in this case) where ever it matches the refseq. In this state, it will only highlight differences/mismatches with a letter and a color change. Zoomed out, the track appears as a solid bar in the FG color for the track. The refseq appears as a gray bar in the coordinate axis.

Copy and paste sequence bases in IGB

You can copy a sequence of bases into another application, such as Notepad. 

To capture a sequence of bases:

  • Make sure that the sequence residues are already loaded. 
  • Either select a single annotation or click and drag in the Coordinates track to select the desired coordinate range.
  • Choose Edit menu > Copy Selected Residues to Clipboard.
  • Paste the text string into the target application or location. 
Icon

If you have selected an annotation that has introns, the selected residues will only include the exon regions.

If you have selected a negative-strand annotation, the selected residues will be reverse-complemented.

If you want to capture all the residues including the intron regions, select the region by dragging in the Coordinates track

  • No labels