Skip to end of metadata
Go to start of metadata

 

All file opening/loading/saving/exporting in IGB should be handled by the native or JavaFX file chooser rather than the non-native file chooser.

Look at the images below to see an example of the native file chooser compared to the non-native file chooser.

Native File Chooser on Windows (Currently being used)

Non-Native File Chooser on Windows (No Longer Used)

 

 


 

Native File Chooser on Mac (Currently Being Used)

 

Non-Native File Chooser on Mac (No longer used)

 

 


Native File Chooser on Linux (Currently being used)

 

 Non-Native File Chooser on Linux (No Longer Used)

 

 

General Function Checklist (perform for each of the file choosers listed below)

  • Start by selecting the action that opens the file chooser

Verify that this file chooser is the native file chooser.

  • mac
  • linux
  • windows
  • Use the file chooser to open/save a file and take note of the directory you are opening from/saving into and the filename you used.
Directory used?FileName used?
  

Verify that the file has opened/saved properly. (Check data, saved location, name, etc.)

  • mac
  • linux
  • windows
  • Use the same file chooser as in the last step to save a file with the same name, in the same directory.

Verify that a pop-up appears asking you to confirm if you would like to replace the file.

  • mac
  • linux
  • windows
  • Reopen the file chooser.

Verify that the file chooser remembered the last used directory and filename.

  • mac
  • linux
  • windows
  • Reset IGB Preferences to Default, restart IGB, and reopen the file chooser.

Verify that the file chooser defaults to the user's home folder.

  • mac
  • linux
  • windows

Locations to test File Choosing:

While performing the below list of actions, ensure that any default filename or list of supported file extensions makes sense.

  • mac
  • linux
  • windows

 

Open File… (under File Menu)

  • mac
  • linux
  • windows

Open Genome from File…(under File Menu)

  • mac
  • linux
  • windows

Save Image…(under File Menu)

  • mac
  • linux
  • windows

Load/Save Session (under File Menu)

  • mac
  • linux
  • windows

Configure Weblinks, Import/Export (under Tools Menu)

  • mac
  • linux
  • windows

Import/Export Bookmarks…(under Bookmarks Menu) 

  • mac
  • linux
  • windows

Add/Edit Data Source, Choose local folder (in Data Sources tab of IGB Preferences)

  • mac
  • linux
  • windows

Personal Synonyms (in Data Sources tab of IGB Preferences)

  • mac
  • linux
  • windows

Add...., Choose local folder [App Repository] (in App Repositories tab of IGB Preferences)

  • mac
  • linux
  • windows

Save PAXML File… (in ProtAnnot file menu)

  • mac
  • linux
  • windows

Save Track As... (in the right-click menu for a track)

  • mac
  • linux
  • windows

 

  • No labels